
Technique  Extension tubes

Increasing the distance between the lens and the sensor or film 
reduces the focusing distance. That’s how macro lenses do it. But 
you can get similar results by fitting an extension tube.

Move closer
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If you are serious about macro photography, 
you probably own a macro lens. They are the 
tool of choice for photographers who want to 
get close to their subjects, but do not want to 
compromise on image quality, ease of use or 
performance.
 However, the performance of macro lenses 
comes at a price – the cost of the lens. But 
what if you would like to dabble in macro or 
close-up photography without the expense of 
buying a macro lens? Is there any way to get 
in closer and obtain increased magnification 
with the range of lenses you already own?
 Extension tubes could be the solution you 
are looking for. The principle is very simple. 
When it comes to close-up photography, your 
lenses are limited by how close to the subject 
they can focus. The closer the focusing 
distance, the further the front element needs 
to be from the sensor plane. This distance is 
called extension – the greater the extension 
the closer you can get to the subject.

 Extension tubes work by increasing 
the lens extension – the physical distance 
between the front element of the lens and the 
film or digital sensor. 
 An extension tube is simply a light-tight 
tube that fits between the camera body and 
lens. The extension of the lens is increased, 
the minimum focusing distance decreases, 
and you can get closer to your subject for 
greater magnification.

Canon makes two extension tubes, the EF 
25 II and EF 12 II. They have a length of 
25mm and 12mm respectively. The EF 25 
II gives more extension, and therefore 
greater magnification, but it is 
more expensive. You can also 
use the two together for even 
more extension. Canon doesn’t 
recommend this (it says data 
transfer may be affected), but it 
worked for us.
 The EF 25 II and EF 12 II 
extension tubes were introduced 

Discontinued extension tubes EF 25 and EF12 

Above Canon 
extension tube EF 25 
II fitted between an 
EOS camera and an EF 
50mm f1.8 lens.

in September 2004 at the same time as the 
EOS 300D camera and EF-S lenses. Prior to 
this date, Canon sold the EF 25 and EF 12 
extension tubes. They are identical to the 

newer versions except in one respect – you 
cannot use them with EF-S lenses. 

These Mark I versions have long 
been discontinued, but you 

may be able to find them on 
the second-hand market. If 
you do not use EF-S lenses 
they could be an economical 

alternative.

Current extension tubes EF 25 II and EF 12 II

Canon extension tubes

Right and opposite 
Shooting square to 
the subject overcomes 
some of the problems 
with the limited depth-
of-field in close-up 
photography. Much of 
the dragonfly is sharp in 
both photographs. They 
were taken using the EF 
12 and EF 25 extension 
tubes mounted 
together on an EF 70-
200mm f2.8L IS USM 
lens. The main light is 
from a Speedlite fired 
through a diffuser to 
avoid hotspots on the 
delicate wings. Slow 
shutter speeds pick up 
the ambient light.
Right 1/15 second at 
f16, ISO 400.
Opposite 1/10 second at 
f16, ISO 100.
Both with EOS 5D Mk II.
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with EF 12 II and
EF 25 II tubes

with EF 25 II
extension tube

Tube magnification
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Extension tubes in action

Extension 
tubes

Lens 
compatibility

Approximate 
retail price* Extension Recommended

focal lengths

EF12
EF, TS-E lenses discontinued

12mm 24-100mm 

EF25 25mm 50-150mm

EF12 II EF, EF-S, TS-E 
lenses

£71.99 12mm 24-100mm 

EF25 II £99.99 25mm 50-150mm

* Varies by dealer. 

The magnification formula
There is a formula for working out how much 
magnification extension tubes will give you:
magnification = extension/focal length
 Every lens has an effective extension. 
Canon does not make this figure available, but 
we can work it out once we know the focal 
length and magnification of a lens, figures 
that Canon do publish. Let’s take Canon’s EF 
50mm f1.8 II lens, as an example. We know 
the focal length (50mm) and Canon gives 
the magnification as 0.15x (this is at the 
minimum focusing distance of 45cm). From 
these figures a little algebra reveals that the 
effective extension built into the lens is 7.5mm 
(extension = magnification x focal length).
 We use the phrase ‘effective’ extension 
because the focal length of the lens can 
change slightly at different focusing distances. 
 Adding the EF 25 II extension tube to 
the lens gives a total extension of 32.5mm. 
To work out the magnification, just divide 
the extension (32.5mm) by the focal length 
(50mm) to give a figure of 0.65x.
 It’s much easier to judge magnification with 
some practical examples. The photos on the 
right show how much magnification you can 
obtain with certain focal lengths.

Magnification and focal length
The above equation also helps to explain the 
effect that extension tubes have on lenses 
of different focal lengths. Using simplified 
figures, we can see that the additional 
magnification of a 50mm lens used with the 
EF 25 II extension tube is 0.5x (25/50). Fit the 
same extension tube to a 100mm lens and 

Left The effectiveness 
of adding extension 
tubes depends on the 
focal length of the lens. 
The shorter the focal 
length, the greater the 
effect. The 17-40mm 
lens has the greatest 
magnification, but 
with a gap of less than 
3cm between the lens 
element and the subject 
when used with the EF 
25 II, it is impractical 
to use at this high level 
of magnification as the 
lens blocks the light.
 The 50mm and 
85mm lenses give 
more practical 
working distances and 
good magnification, 
especially when the 
two extension tubes are 
combined.
 The 70-200mm 
lens does not benefit 
as much from the 
extension tubes. If you 
have this focal length 
lens, the 500D or 
250D close-up lenses 
will give you greater 
magnifications.

Magnification is determined by the focal 
length and the extension of the lens. 
From this we can see that the crop factor 
of the camera you use is not even a 
consideration. However, in practice, the 
crop factor does make a difference to the 
apparent magnification. This is because 
at a magnification of, say 1x, an object 
that measures 36mm by 24mm will be 
reproduced at life size on a full-frame 
camera. An APS-C camera, on the other 
hand, will only record the central part of 
the object, an area of approximately 15 x 
22.5mm (the exact sensor size varies by 
model). Compare the two images side by 
side and it appears that the photo taken 
with the APS-C size camera has greater 
magnification. This means that an APS-C 
camera appears to get you closer to your 
subject than a full-frame camera.

Above This photo was taken with an 
EF 85mm f1.8 lens on an EOS 40D. 
The lens was set to its minimum 
focusing distance of 85cm. This 
photo is as close as the photographer 
can get with this lens. 

Above This photo was taken with 
the same 85mm lens focused at its 
minimum focus setting, and with the 
EF 12 extension tube fitted. However, 
instead of focusing at 85cm, the 
lens can now focus at a distance of 
approximately 53cm from the subject. 

Above The 85mm lens was focused 
at its minimum focusing distance. 
With the EF 25 extension tube fitted, 
the photographer could move within 
39cm of the subject.

Right The EF 25 and EF 12 extension 
tubes were combined, giving a total 
extension of 37mm. The 85mm lens 
was set to its minimum focusing 
distance, enabling a sensor plane to 
subject distance of 34cm.

Minimum focusing distances

Extension tubes

Lens

17-40mm f4L
at 40mm 50mm f1.4 85mm f1.8 70-210 f4L IS

at 210mm

None 28cm 45cm 85cm 120cm

EF12 / EF12 II 23cm 27cm 51cm 102cm

EF25 / EF25 II 22cm 22cm 41cm 90cm

EF12 + EF25 or 
EF12 II + EF25 II

N/A* 21cm 37cm 62cms

* Lens cannot focus on the subject at this extension.

Above EF 50mm f1.4 lens

Above EF 85mm f1.8 lens

Above EF 70-200mm IS f4L lens at a focal length of 200mm 
All photos taken 
with an EOS 40D.

minimum focus
of lens

with EF 12 II
extension tube

Right The top picture 
shows the image 
captured by a full-frame 
sensor. The white 
rectangle shows the 
area seen by an APS-C 
sensor. (Assuming 
the same lens is used 
on each camera to 
take the picture.)
Both images have the 
same magnification. 
However, if you want 
both images to fill the 
same print area, the 
APS-C image has to be 
enlarged more than the 
full frame image. The 
result is that th APS-C 
camera appears to give 
greater magnification.

the magnification drops to 0.25x (25/100). So 
the longer the focal length, the less effect is 
gained from adding extension tubes. This 
explains why extension tubes are more useful 
with lenses of shorter focal lengths.
 Does this mean that you can use the EF 25 
II extension tube with a 24mm lens for 1.0x 
magnification? Unfortunately not, because the 
minimum focusing distance is greater than the 
distance from the camera’s sensor plane to 
the subject required for 1:1 magnification. You 
cannot focus on the subject – only on a point 
somewhere behind it.

Crop factor effect

Above EF 17-40mm f4L lens at a focal length of 40mm. The front lens element 
was less than 3cm from the stamps for the third photo and has cast a shadow. It 
is not possible to focus with both tubes attached.

 Unsuitable     
 lenses

The EF 14mm, and 
EF 15mm lenses are 
unsuitable for the EF12/
EF12 II extension tubes. 
These lenses, plus the 
EF 20mm and EF 24mm 
are unsuitable for the 
EF25/EF25 II extension 
tubes. Zoom lenses at 
these focal lengths are 
also unsuitable.

NO TUBE

EF 12 TUBE EF 25 TUBE

EF 12 + EF 25 TUBE
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Focus stacking

Focus stacking is a technique which can be 
used to achieve front-to-back sharpness in 
close-up images with shallow depth-of-field.

Depth-of-field
Depth-of-field is determined by three factors: 
• the focal length of the lens 
• the aperture
• the distance between the lens and subject. 
Of the three, the third factor has the greatest 
affect on depth-of-field. The closer your lens 
is to your subject, the less depth-of-field 
you have. When shooting close-up or macro 
photography with extension tubes, depth-of-
field may be so limited that you cannot obtain 
front to back sharpness even at f16 or f22. 
This holds true regardless of focal length. 

Diffraction
Another problem is diffraction. Diffraction 
is a kind of lens distortion that starts to 
appear at small apertures, such as f16 and 
f22. Diffraction degrades image quality – look 
closely at the same image taken with the same 
lens at apertures of f8 and f22 and you might 
see a significant difference in image quality. 
The image taken at f22 may have more depth-
of-field, but appears to be less sharp than the 
image taken at f8 because of diffraction.

Above A different part 
of the flower is in focus 
in each of the photos. 
The focus stacking 
technique blends them 
all together to create a 
new image comprising 
the sharp zones in each 
photo (see main image).

without focus stacking with focus stacking

1  If you shot the photos in RAW, 
process them identically in Digital 
Photo Professional (DPP) or other 
RAW conversion software. 

2  DPP users: Go to File > Batch 
Process and save the images in the 
JPEG format in a new folder (set 
Image quality to 10).

3  Open Adobe Bridge, navigate 
to the new folder and select all the 
images (Edit > Select all).

4  Go to Tools > Photoshop > Load 
files into Photoshop layers. This loads 
the selected photos into Photoshop 
CS 4 and combines them into a single 
file with each photo in its own layer.

5  The photos need to be aligned. 
Each photo is slightly different, as at 
such close lens-to-subject distances 
the effective focal length of the lens 
changes when you focus on different 
points. To fix this, go to Select > 
All layers then Edit > Auto-Align 
Layers... Select ‘Auto’ and press OK. 
Photoshop aligns the layers.

6  To blend the sharp parts of the 
layers together, go to Edit > Auto-
Blend Layers, Select ‘Stack Images’ 
and tick ‘Seamless Tones and 
Colours’ then press OK. It will take a 
few minutes. When done, go to Layer 
> Flatten Image to flatten the layers 
and then save the photo. 

Helicon Focus is very easy to use. 
Start by clicking the Add Images 
button to load your photos and clear 
any other images already there. Press 
the Render button (you can play with 
focus parameters, but the default 
ones worked fine for us) and then the 
Saving button to save the image once 
the blending process has finished.

• Use a tripod and cable release 
to keep the camera in the same 
position for every shot. Be 
careful not to jog the tripod.

• Avoid camera shake caused by 
camera vibration at slow shutter 
speeds by enabling the mirror 
lock-up in the Custom Functions 
menu.

• Take two exposures at each 
setting when using slow shutter 
speeds as insurance against any 
spoilt by camera shake.

• Use ISO 100 for maximum image 
quality and colour saturation, or 
a high ISO like 1600 or 3200 for a 
grainy effect caused by noise.

• Use the Quick Control screen, 
if your camera has it. It is much 
easier to see your aperture, 
shutter speed and ISO settings 
here than on the LCD panel on 
top of the camera.

• If you have more than one EOS 

Helicon Focus Focus stacking tips

camera, try using the one with 
fewer megapixels. This produces 
smaller files, which are easier 
for your computer to handle, 
particularly if you are blending 
a lot of photos or have a slow 
computer.

• Shoot RAW + JPEG, and make 
sure that you set the Picture 
Style, white balance, aperture and 
shutter speed manually. Shoot 
each photo at the same ISO, 
aperture and focal length. If your 
settings are accurate, you can 
blend the JPEG files straight out of 
the camera, and you have the RAW 
files as insurance in case you need 
to tweak any settings afterwards. 

The solution
Focus stacking involves taking several photos, 
all at the same aperture (ideally f8 or f11 – 
the sharpest settings for most lenses) each 
with a slightly different point of focus. The 
first image is focused towards the front of 
the subject, the next a little further back, and 
so on. The aim is the have every part of the 
subject in focus in at least one of the images. 
You then blend the images using dedicated 
software to create a photo with back-to-front 
sharpness. Adobe Photoshop CS4 and CS5, 
have an auto-blending function for focus 
stacking. If you use Windows, CombineZM 
is a free program that does the same. It’s 
available from: 
http://hadleyweb.pwp.blueyonder.co.uk/
CZM/News.htm. 
 Helicon focus is a program available for 
both Mac and PC users at: 
www.heliconsoft.com. 
Licenses start from $30US, and you can 
download the program and try it for 30 days 
without any restrictions.
 We tested Adobe Photoshop CS4 and 
Helicon Focus. Both programs worked 
flawlessly – Helicon Focus was much quicker 
and easier to use, but cropped tighter into the 
image than Photoshop CS4. 

Focus stacking in Photoshop

As far as we know, focus 
stacking is exclusive to digital 
photography. Unlike many other 
digital techniques, it does not 
appear to be an implementation 
of a film technique. It is not the 
answer to every depth-of-field 
issue, but it will solve a few 
tricky problems.
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For my water droplet photos I use an 
EF 100mm Macro lens with an EF 25 II 
extension tube and manual focus to get the 
biggest, clearest droplet possible. I always 
use a tripod and work with natural light.
 I shoot my water drop shots indoors as 
it’s usually somewhat breezy where I live, 
but I have good light from large windows. 
I set up the flower with the background 
positioned between 6 to 12 inches behind 
it, depending on the desired result. 
 I place the water droplet on the petal 
with a syringe and adjust the background 
so that I can see it in the drop. It can be 
a little time consuming, even frustrating, 
to get a drop to a nice shape and make 
it stay in place. The droplet has to be 
positioned to get an unobscured view of 
the background. 
 Sometimes I use printed matter such 
as gift wrap or greeting cards to produce 
the refracted image in the water droplet. 
Designs with bright clear colours give the 
clearest refractions. The image will be 
inversed in the water drop. I position the 
background sheet upside down so that 
the design shows the right way up in the 
refraction. I also like to use flowers – again 
the brightest coloured flowers make the 
clearest images.

Rodel Manabat      Case studies

I have always been fascinated by macro 
subjects, especially insects. I used to own 
an EF 100mm f2.8 Macro lens, but it was 
rather frustrating not being able to take the 
shots I had in mind. So I sold my macro lens 
and changed my set up to a more compact 
solution. I now use an EF 12 II extension tube 
with an EF 24-70mm f2.8L lens. It is easier, 
quick to change and a great combination with 
a fast aperture lens. It is a bit heavier than 
the 100mm f2.8 Macro lens, but it serves a 
dual purpose – a general walk around lens 
and a good macro option (by attaching the 
extension tube).  
 I like taking close-up and macro shots of 
plants, leaves, flowers, petals, butterflies, 
water droplets and insects – anything with 
symmetry, lines and interesting texture.  
 Most of the time I use my EF 12 II tube with 
my EF 24-70mm f2.8L. I normally shoot at the 
70mm focal length. Using the rule of thumb 
for calculating magnification (magnification 
= extension/focal length), at 70mm the 
magnification is 12mm/70mm = 0.17x.  
 I set the focusing to manual or automatic 
depending on the subject. If the subject is 
moving (such as insect, flower, plant, droplets 
on leaves) then it is better to focus manually.
 If your subject is fixed you can mount your 
camera on a tripod, set autofocus and use 

a shutter release cable to minimize camera 
shake. I prefer to use a wider aperture (f2.8 to 
f4) to draw attention to only a portion of the 
subject. I use selective focusing from the 9 
autofocus points of my camera. If there is too 
much movement in the subject AI focusing is 
of great advantage.    
 Flash is important. I used to ignore 
using the camera’s built-in flash, but after 
colleagues showed me the advantage of using 
flash it has now become part of my set-up. I 
also use a Speedlite 580EX II with a Stofen 
OmniBounce diffuser.
 

Third party 
EOS-fit extension 
tubes are made by 
other companies and 
are less expensive 
than those from 
Canon. However, the 
build quality can be 
inferior and we have 
not come across any 
that are compatible 
with EF-S lenses. 
Canon extension 
tubes maintain full 
electrical contact 
between the camera 
body and lens, so 
that you can stop 
down the aperture 
and, if you want to, 
use autofocus. It 
is possible to buy 
extension tubes for 
under £10, but the 
catch is that they 
have no electrical 
contacts. You cannot 
stop down your 
lens and use a small 
aperture as EF lenses 
do not have manual 
aperture rings. This 
means that you will 
be limited to using 
your lens at its widest 
aperture, unable to 
increase the depth-
of-field.

Tube pros and cons

The big advantage of extension tubes is that 
they can be used with nearly any lens. They 
can also be used in combination with close-
up lenses (covered in the July–September 
2010 issue), or with a macro lens, for even 
greater magnifications. 

Light loss
There is one major disadvantage – adding 
an extension tube reduces the amount of 
light reaching the film or digital sensor. 
This means that you need to increase the 
exposure by increasing the ISO, using a 
slower shutter speed or setting a wider 
aperture. Light loss can be as much as two 
stops at higher magnifications – although 
you always have the option of using off-
camera Speedlites so that you can use low 
ISOs and small apertures. Both Lee Beel 
and Rodel Mandabat, whose photos appear 
in this article, use Speedlite flashes with 
diffuses fitted to them for this reason.
 Of course, much of the time you might 
not be aware of this light loss. Unless you 
are using the manual shooting mode, the 
camera’s through-the-lens metering system 
will automatically adjust the exposure values 
to give correct exposure. However, it will 
reduce your creative options for smaller 
apertures or faster shutter speeds.

Focus shift
Another disadvantage occurs when you 
use extension tubes with zoom lenses. If 
you change the focal length of the lens, the 
focusing distance changes as well, and you 
need to refocus. You can get around this by 
selecting the focal length you want to use 
first (normally the longest) before focusing.
 You don’t have this problem if you are 
using a prime (fixed focal length) lens.

Telephoto lenses
Extension tubes work best with lenses that 
have a focal length of between 35mm and 
150mm. Below 35mm, you may need to 
get so close to your subject to focus that it 
becomes impractical. With longer telephoto 
lenses, the increase in magnification is so 
slight that using extension tubes may not 
be useful. Canon’s 250D or 500D close-up 
lenses will get you much closer. 

Image quality
While Canon’s double element close-up 
lenses, the 250D and 500D, are high quality 
close-up lenses that have a minimal effect 
on image quality, less expensive close-up 
lenses can degrade image quality quite 
badly. Extension tubes contain no glass and 
so have little impact on image quality.

Above The 
effectiveness of 
adding extension 
tubes depends on 
two factors – the 
focal length of 
the lens and the 
minimum focusing 
distance. The shorter 
the lens, and the 
closer its minimum 
focal distance, the 
greater the level of 
magnification will be 
gained from adding 
an extension tube.

May-lin Joe

The photos on this 
page were taken using 
an EF 24-70mm lens set 
to 70mm and fitted with 
an EF12 II extension 
tube. The depth-of-
field is very narrow 
but Rodel has used 
this limitation to great 
creative effect.
Above EOS 40D, EF 
24-70mm f2.8L lens 
with EF 12 II Extension 
tube, ISO 100, f2.8, 1/40 
second.
Right EOS 40D, EF 24-
70mm f2.8L lens with 
EF 12 II Extension tube, 
ISO 400, f2.8, 1/200 
second.

Both Rodel and 
May-lin can be 
found online at 
Flickr. You can 
view their galleries 
at www.flickr.
com/photos/
rodjbman71 and 
www.flickr.com/
photos/mayj 
respectively.


